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• Using OLE with Excel
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• Sharing Excel Data Over the Web

• Retrieving External Data with Excel

One of Excel 2000’s distinguishing new features relates to sharing information— both
between programs and within a workgroup. Excel now fully recognizes that many

users—you may be one—use several programs in their work and use Excel in a workgroup
environment. This chapter describes the tools and features that Excel provides for sharing
data among users and between programs.

Using OLE with ExcelUsing OLE with ExcelUsing OLE with ExcelUsing OLE with ExcelUsing OLE with Excel
Microsoft Windows itself provides a powerful and easy-to-use tool for sharing data known
as OLE, or Object Linking and Embedding. With OLE, you can transfer data between
Excel and other Windows’ programs, as described in the paragraphs that follow.

How OLE WHow OLE WHow OLE WHow OLE WHow OLE Worksorksorksorksorks
In order to make sense of OLE, it’s helpful both to understand the basic operation of the
Windows clipboard and the terminology of OLE. The following paragraphs provide this
background information.
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Anytime you use the Copy or Cut command, Windows stores your copy of the copied or
cut selection using the Clipboard. When you later choose the Paste command, the Win-
dows program—this might be Excel—retrieves what is stored on the Clipboard and pastes
it into the worksheet at the location of the cell marker or insertion bar.

While you most often use the Clipboard to move and copy data within a program like Excel,
you can also use the Clipboard data between programs because the contents of the Clip-
board are stored until you exit Windows.

NOTENOTENOTENOTENOTE Microsoft     Office programs store multiple selections on the Clipboard. When you
choose the Paste command and the Clipboard holds multiple copied or cut selections,
you can choose which selection gets pasted.

OLE is simply the name that Microsoft has given to this Clipboard-based method of sharing
document data. With OLE you can use a chart from an Excel workbook in a Microsoft Word
document. In this case, and using the terminology of OLE, Excel is the server application,
the Excel workbook is the source, Word is the client application, and the Word document
is the container.

OLE objects can be either static, or embedded, which means that what gets stored in the
container document is simply a copy. And OLE objects can also be dynamic, or linked, which
means that the client application actually retrieves a picture of the actual data from the server
application. With a linked object, this “picture” changes as the data changes.

NOTENOTENOTENOTENOTE You choose between embedded objects and linked objects on the basis of whether you
want the object to change. If you don’t want the object to change—perhaps because
the container document shouldn’t be revised—you embed. If you want the object to
change—because you automate updating of the container document—you link.

Although OLE provides you with powerful opportunities to share data between programs,
you’ll find it easy to use. You create an OLE connection by copying and pasting the data
you want to share. Windows hides the complexity from you and takes care of the actual work
of data sharing.

Creating an Embedded OLE ObjectCreating an Embedded OLE ObjectCreating an Embedded OLE ObjectCreating an Embedded OLE ObjectCreating an Embedded OLE Object
As an example of how to create an embedded OLE object, suppose that you do want to use
an Excel chart created in a Word document. To easily create such an embedded OLE ob-
ject, follow these steps:

1. Open both the source and destination documents.
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To most easily create embedded OLE objects, start both the server application and the
client application. You should also open both the source document and the container
document. If you’re working with brand-new, as-yet unsaved documents, first save them.

NOTENOTENOTENOTENOTE To easily create OLE connections, you need to run more than one program at the same
time, which is called multitasking. The Windows Taskbar lets you easily run multiple
programs at once. To start a second program, for example, use the Start button to
start the program in the usual way. To switch between running programs, use the task
buttons on the Taskbar.

2. Select the chart object.

To select an object, simply click it. For example, to select the chart object shown in Fig-
ure 7-1, simply click the chart.

Figure 7-1 An Excel chart such as you might use for an OLE source document.

3. Copy the object to the clipboard.

You can copy and object to the clipboard by clicking the Copy toolbar button. Or you
can choose the Edit menu’s Copy command.

4. Display the source document.

You could do this by clicking the document’s button on the Taskbar. If you wanted to
copy the object to a Word document named Report, you would click the Report taskbar button.

5. Position the insertion point at the location where you want to paste the object.

You can typically position the insertion point by clicking the point in the document where
you want to place the object. For example, if you wanted to paste a chart object after the first
paragraph, as shown in Figure 7-2, you would click on the line following the first paragraph.
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Figure 7-2 A Word document such as you might use for an OLE destination document.

6. Paste the chart object into the client application’s container document.

You can paste an object to the clipboard by clicking the Paste toolbar button. You can also
choose the Edit menu’s Paste command. When you do, the client application (with Windows’
help) creates an embedded object that looks as much like the source document object as the
server application, Windows, and the client application allow. In other words, Windows and
Windows programs use the richest format available for the pasted object. Figure 7-3 shows
the Excel chart from Figure 7-1 embedded in the Word document from Figure 7-2.

Figure 7-3 The Word document after adding the Excel chart object.
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Creating a Linked OLE ObjectCreating a Linked OLE ObjectCreating a Linked OLE ObjectCreating a Linked OLE ObjectCreating a Linked OLE Object
You create a linked OLE object in almost the same way as you create an embedded OLE
object. There’s just one minor twist. You use the Edit menu’s Paste Special command be-
cause it lets you indicate you want to create a linked object. For example, to create a linked
OLE object using the same Excel chart shown in Figure 7-1 and the same Word document
shown in Figure 7-2, follow these steps:

1. Open both the source and container documents.

Again, to easily create embedded OLE objects, both the server application and the cli-
ent application must be running and both the source document and container document
should be open.

2.  Select the chart object.

As mentioned earlier, to select an object you simply click it.

3. Copy the object to the clipboard.

You can copy an object to the clipboard by clicking the Copy toolbar button or by choosing
the Edit menu’s Copy command.

4. Display the source document.

You could do this by clicking the document’s button on the Taskbar.

5. Position the insertion point at the location where you want to paste the object.

You can typically position the insertion point by clicking the point in the document where
you want to place the object.

6. Paste the chart object into the client application’s container.

This is the only step that works differently from pasting an embedded object. When you
paste a linked object, you need to use the Edit menu’s Paste Special command. When
you choose this command, the client program displays a Paste Special dialog box. (Fig-
ure 7-4 shows Microsoft Word’s version of the Paste Special dialog box, but other
program’s Paste Special dialog boxes look almost the same and work in the same basic
way.) When the client program displays its Paste Special dialog box, click the Paste Link
option button and click OK. Optionally, you can also select a format for the object from
the As list box.
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Figure 7-4 The Paste Special dialog box.

When you open a document into which you’ve placed linked OLE objects, the program asks
whether you want to update the links. If you do, click Yes, and the client application retrieves
updated information from the source document.

NOTENOTENOTENOTENOTE  If you don’t want the client application to automatically update links, you can tell it
not to do so. To make this specification, in Excel, for example, choose the Tools menu’s
Options command, click the Calculation tab, and then clear the Update Remote Ref-
erences check box.

By the way, it’s possible to inadvertently break a link. For example, this may happen if the
same source document is moved or renamed while the client application and container
document are closed. In this case, you need to reestablish the link by repeating the steps you
took to originally establish the link.

Editing OLE ObjectsEditing OLE ObjectsEditing OLE ObjectsEditing OLE ObjectsEditing OLE Objects
You can easily modify linked and embedded objects. To change an object, double-click it. The
client application starts the server application and opens the appropriate source document.
Once the server application is running and displaying the source, you can make your changes.

Inserting OLE Objects in Excel WInserting OLE Objects in Excel WInserting OLE Objects in Excel WInserting OLE Objects in Excel WInserting OLE Objects in Excel Workbooksorkbooksorkbooksorkbooksorkbooks
The object sharing method described in the preceding paragraphs works well in situations
in which you want to share data between programs and display that shared data in the con-
tainer document. You should also know, however, that Excel’s Insert menu provides an Object
command, which you can use to place icons in a workbook that point to source documents.
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To use the Insert menu’s Object command to point to new OLE objects, choose the Insert
menu’s Object command. When Excel displays the Object dialog box (see Figure 7-5), click
the Create New tab, select the program necessary to create the object, and then click OK.
Excel starts the server application, and you use it to create the new object. When you fin-
ish creating the object, click outside the object—such as on a worksheet cell—to return to
Excel. Use the Display As Icon check box to indicate whether you want to see a picture of
the object or simply a clickable icon you can use to access the object.

Figure 7-5 The Create New tab of the Object dialog box.

To use the Insert menu’s Object command to point to an existing document, you also choose
the Insert menu’s Object command. When Excel displays the Object dialog box, however,
you click the Create From File tab and then identify the file you want to use to create the
object (see Figure 7-6). To identify the file, enter the complete pathname in the Name box
or use the Browse button to display a dialog box you can use to search disks and folders for
the file. Select the Link To File check box if you want to create a linked object. Select the
Display As Icon check box to indicate whether you want to see a picture of the object or
simply a clickable icon you can use to access the object.
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Figure 7-6 The Create From File tab of the Object dialog box.

Sharing WSharing WSharing WSharing WSharing Workbook Filesorkbook Filesorkbook Filesorkbook Filesorkbook Files
Excel provides several useful tools for sharing your actual workbooks, rather than just the
information they contain. You can tell Excel to save or open workbooks in formats accept-
able to other spreadsheet programs. You can direct Excel to save your workbooks on a net-
work drive and then make the workbook simultaneously available to multiple users. And
you can use electronic mail as a means of passing a workbook to other users.

NOTENOTENOTENOTENOTE Excel also provides tools for publishing Excel workbooks to web sites as web pages,
or HTML documents, and for placing interactive Excel objects into web pages. At the
end of this section, I’ll discuss these tools and explain why you will probably never want
to use them.

Sharing Excel WSharing Excel WSharing Excel WSharing Excel WSharing Excel Workbooks with Other Programsorkbooks with Other Programsorkbooks with Other Programsorkbooks with Other Programsorkbooks with Other Programs
You can rather easily share an Excel workbook with other spreadsheet programs. You can,
for example, export an Excel workbook so someone using Lotus 1-2-3, another popular
spreadsheet program, can open and work with the workbook. And you can also easily im-
port spreadsheet documents created by other programs into Excel. For example, you can
import a Quattro Pro workbook into Excel.

Exporting a WExporting a WExporting a WExporting a WExporting a Workbookorkbookorkbookorkbookorkbook
To export a workbook, you use the File menu’s Save As command. When Excel displays
the Save As dialog box, save the workbook file in the usual way—except use the Save As
Type drop-down list to specify the file format as one acceptable to the other program (see
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Figure 7-7). For example, if you want to export an Excel workbook to Lotus 1-2-3, choose
the appropriate 1-2-3 file format.

Figure 7-7 The Save As dialog box set to use the Lotus 1-2-3 format.

NOTENOTENOTENOTENOTE You may need to determine the precise file format acceptable to the program that
will later import the workbook you’re exporting. Different versions of Lotus 1-2-3, for
example, use different flavors of the standard 1-2-3 file format. Usually, if you know
the file extension the spreadsheet program uses, you’ll have enough information to
select the appropriate format.

If you can’t determine the appropriate file format for the exported workbook file, you can
try one of two tactics: You can use a simple standard spreadsheet format such as the tab-
delimited format or the CSV (or comma separated value) format, which all spreadsheet
programs understand. Or you can use a popular spreadsheet format, such as the Excel 95
file format or the Lotus 1-2-3 version 3 file format, which almost all spreadsheet programs
understand.

NOTENOTENOTENOTENOTE If you have questions about how to work with the other options on the Save As dia-
log box, refer to Chapter 2.

Importing a Spreadsheet DocumentImporting a Spreadsheet DocumentImporting a Spreadsheet DocumentImporting a Spreadsheet DocumentImporting a Spreadsheet Document
To import a spreadsheet document, you use the File menu’s Open command. When Excel
displays the Open dialog box, you open the to-be-imported document in the usual way—
except you use the Files of Type drop-down list to specify the file format of the document
you want to import (see Figure 7-8). For example, to import a Lotus 1-2-3 spreadsheet
document, select Lotus 1-2-3 Files from the list.
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Figure 7-8 The Open dialog box with the Files Of Type list box indicating the Lotus 1-2-3 Files
will be opened.

It’s unlikely but not impossible that Excel won’t recognize the other spreadsheet program’s
file format. In this case, before you save the spreadsheet document using this other spread-
sheet program, you may need to choose a file format that Excel understands such as any
version of Excel, any version of Lotus 1-2-3, or a standard simple format such as CSV or
Tab-delimited

NOTENOTENOTENOTENOTE If you have questions about how to work with the other options on the Open dialog
box, refer to Chapter 2.

Sharing Excel WSharing Excel WSharing Excel WSharing Excel WSharing Excel Workbooks Over a Networkorkbooks Over a Networkorkbooks Over a Networkorkbooks Over a Networkorkbooks Over a Network
You can share an Excel workbook with other Excel users over a network. In a nutshell, all
you have to do is save the workbook in some accessible location, such as on a network drive
or a shared local drive. With a workbook located on a network or shared local drive, net-
work users with the appropriate level of authority and the requisite permissions can open,
edit, and save the workbook.

NOTENOTENOTENOTENOTE To view or open a network or shared local drive, you need to first map to the drive.
You can map to a drive by clicking the Command and Settings buttons in the Open
or Save As dialog boxes, choosing the Map Network Drive command, and then en-
tering the full pathname for the drive. If you have questions about the network
pathname, ask your network administrator.
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If you do share a workbook over a network, you should be aware of a couple of points. First,
and in general, if one user opens a workbook, other people can’t open that same workbook
except as a read-only document. What that means is that the person can’t save the work-
book using the same, original filename. The user can, however, save the workbook using a
new filename or in a new location.

Excel tells you when you attempt to open a workbook that it’s already being used. It then gives
you the option of opening the workbook in read-only mode (see Figure 7-9). You also have
the option of asking Windows to notify you when the workbook document is fully available.

The second point you need to know about sharing a workbook over a network is that you
have the option of telling Excel it’s okay for multiple users to open and make changes to
the same workbook. I can’t emphasize enough that this option is extremely difficult to suc-
cessfully use in a real-life work setting. You can just imagine all the trouble that can occur
if people start making the same sorts of changes to the same parts of a workbook. If you
want to do this, however, choose the Tools menu’s Share Workbook command. When Excel
displays the Share Workbook dialog box (see Figure 7-9), select the Allow Changes By More
Than One User At The Same Time check box.

NOTENOTENOTENOTENOTE The Share Workbook dialog box, as shown in Figure 7-9, also lists the names of the
users who’ve opened a workbook.

Figure 7-9 The Editing tab of the Share Workbook dialog box.
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You can control many aspects of Excel’s workbook sharing by using the Advanced tab of
the Share Workbook dialog box (see Figure 7-10). The Track Changes options, for example,
let you tell Excel that it should keep a list of the changes made to a shared workbook and
for how long this list should be kept. The Update Changes options let you specify when and
how the shared workbook is updated for the changes that people make. Finally, the Con-
flicting Changes Between Users options let you specify what should happen when changes
from different users are in conflict.

Figure 7-10 The Advanced tab of the Share Workbook dialog box.

Excel does attempt to resolve any conflicts that arise from workbook sharing. When a user
saves a workbook, Excel looks for conflicts—such as the same cell being changed by dif-
ferent users. If Excel sees such a conflict, it displays the Resolve Conflicts dialog box (see
Figure 7-11) and asks how the conflict should be resolved. One important aspect of this
conflict resolution, however, is that the person who saves the workbook and, therefore, sees
the Resolve Conflicts dialog box, determines which changes should be saved and which
should be discarded.
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Figure 7-11 The Resolve Conflicts dialog box.

NOTENOTENOTENOTENOTE If you choose to work with shared workbooks, you probably want to create a formal,
perhaps written, policy to document how conflicts should be resolved. You may also
want to plan for workbook sharing when you build the workbook. For example, you
might build a workbook so different users would always be making changes to sepa-
rate worksheets. This would prevent most conflicts.

Sharing Excel WSharing Excel WSharing Excel WSharing Excel WSharing Excel Workbooks with E-Mailorkbooks with E-Mailorkbooks with E-Mailorkbooks with E-Mailorkbooks with E-Mail
Excel’s File menu provides several commands, which you can use to share workbooks us-
ing electronic mail. When you share workbooks in this manner, you simply attach the
workbook to an e-mail message and then send the message and its attachment, the work-
book, to another person.

NOTENOTENOTENOTENOTE If you can’t e-mail someone a workbook, save the workbook to a floppy disk and
deliver the disk.

Sending a WSending a WSending a WSending a WSending a Workbook via E-Mailorkbook via E-Mailorkbook via E-Mailorkbook via E-Mailorkbook via E-Mail
If you regularly use e-mail, you’ll find it very easy to share workbooks using mail. You sim-
ply send e-mail messages laden with Excel workbooks.

To e-mail the open Excel workbook, follow these steps:

1. Choose the File menu’s Send To command.

Excel displays the Send To submenu, which lists commands for sharing workbooks us-
ing electronic mail and, in some cases, other e-mail-like services, such as Microsoft’s
Exchange Server.
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2. Choose the Send To menu’s Mail Recipient (As Attachment) command.

Excel opens your default e-mail client, opens a new message, and attaches the workbook.
Figure 7-12 shows how the Outlook Express e-mail client looks, but your e-mail client
will probably look very similar even if you use one of the other popular e-mail programs.

Figure 7-12 The Outlook Express message window with an Excel workbook attachment.

3. Complete and deliver the e-mail message in the usual way.

You complete your e-mail message in the usual way. For example, you need to provide
the recipient’s e-mail name or alias. And you probably want to provide a message sub-
ject and perhaps some message text to explain the message and your attachment. When
you finish, send the message in the usual way.

NOTENOTENOTENOTENOTE Some mail servers limit the size of the attachments they will accept. Some organiza-
tions discourage and even prohibit e-mail attachments because the attachments can
contain viruses. Before you send an e-mail attachment, make sure that your recipi-
ent can accept an e-mail message with an attachment.

Receiving a WReceiving a WReceiving a WReceiving a WReceiving a Workbook via E-Mailorkbook via E-Mailorkbook via E-Mailorkbook via E-Mailorkbook via E-Mail
You can also easily receive e-mail messages that contain Excel workbook attachments.

To receive and use an e-mailed Excel workbook, follow these steps:

1. Start your e-mail program and retrieve your messages in the usual way.

Figure 7-13 shows the Outlook Express program window with the Inbox folder displayed.
Other e-mail programs typically show your incoming messages in a similar way. The first
message includes a paperclip icon in front of it to indicate that a file is “attached.”
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Figure 7-13  The Outlook Express Inbox folder showing incoming messages.

2. Open the e-mail message with the attachment.

Figure 7-14 shows the Outlook Express message window displaying a sample message
with an Excel workbook attachment. Again, your e-mail client will probably look very
similar even if you use another program.

Figure 7-14 The Outlook Express message window with an Excel workbook attachment.

3. Save the attachment.
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You can typically do this by right-clicking the attachment icon and then choosing the
Save As command from the shortcut menu. The e-mail client then displays a Save As
dialog box, and you use it to indicate where you want to save the workbook.

4.  Open the workbook.

You open the workbook in any of the usual ways. For example, you can start Excel and
then use the File menu’s Open command.

AAAAAvoiding E-Mail Attachment Problemsvoiding E-Mail Attachment Problemsvoiding E-Mail Attachment Problemsvoiding E-Mail Attachment Problemsvoiding E-Mail Attachment Problems
E-mail attachment problems may be occurring more infrequently these days as the e-mail
clients and the mail servers get smarter. Nevertheless, you should be aware that two prob-
lems are commonly encountered when sending attachments over the Internet: problems with
attachment size and problems with attachment format.

Problems with attachment size stem from the fact that some mail servers limit attachment
size. For example, a mail server may limit attachment size to less than one megabyte, and
that may mean your largest Excel workbooks are too big to be attachments.

Problems with attachment format stem from the fact that an attachment can actually be
included in a message in either of two formats: Uuencode or MIME. Some e-mail programs
accept only one format or may by default assume that attachments use one of the formats.
For example, an e-mail client may assume that attachments are Uuencode attachments and
then become confused when trying to handle a MIME attachment.

While both problems are frustrating, fortunately neither problem is typically difficult to solve.
If you encounter the first problem of attachment size, consult with the mail server admin-
istrators—and ask to have the attachment size limit changed. If you encounter the second
problem of incompatible attachments, consult the e-mail client documentation to deter-
mine how to specify which format is used or assumed—and then make sure that both the
sender’s and recipient’s e-mail clients use the same format.

WWWWWorkbook Sharing with E-Mailorkbook Sharing with E-Mailorkbook Sharing with E-Mailorkbook Sharing with E-Mailorkbook Sharing with E-Mail
In the earlier chapter section, “Sharing Excel Workbooks Over a Network,” I noted that if
you enable workbook sharing, Excel will allow multiple users to simultaneously open a work-
book. Then when these users attempt to save their changes, Excel looks for conflicts and
attempts to help users resolve conflicting changes.

It turns out that you can have Excel also perform this same conflict resolution with workbooks
you’ve shared, such as through e-mail or by physically delivering the workbook on a floppy
disk. To use Excel’s Workbook Sharing feature in these special cases, follow these steps:
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1. Turn on Workbook Sharing.

In order to merge workbooks, you need to first turn on the Workbook Sharing in the
workbook by using the Tools menu’s Share Workbooks command. This is described in
the previously referenced chapter section.

2. Create identical copies of the same workbook.

You can create an identical copy by using the File menu’s Save As command. Simply save
the workbook using a new name.

3. Distribute separate copies of the workbook you want to share.

You can do this by e-mailing the workbook, as described in the earlier chapter section,
“Sending a Workbook via E-Mail.”

4. Collect the workbooks once changes are made.

Once people have made their changes, collect the workbooks. Save them in the same
folder location.

5. Open your master workbook.

The master workbook is the workbook in which you’ll collect all of the changes, and it’s
probably the same workbook you used to create the workbook copies you distributed.

6. Choose the Tools menu’s Merge workbooks command.

Excel displays the Select Files To Merge Into Current Workbook dialog box (see Figure 7-15).

Figure 7-15 The Select Files To Merge Into Current Workbook dialog box.

7. Select the workbooks you want to merge.
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The Select Files To Merge Into Current Workbook dialog box works in the same basic
way as the Save As and Open dialog boxes. You use the Look In drop-down list box to
select the drive and folder you want to open. The main box of the dialog box lists the Excel
workbooks in the open folder. To select a workbook, click it. To select multiple workbooks,
hold down the Ctrl key and then click each work. Then click OK. Excel begins merg-
ing the changes from the selected workbooks into the master workbook.

Using E-Mail Routing SlipsUsing E-Mail Routing SlipsUsing E-Mail Routing SlipsUsing E-Mail Routing SlipsUsing E-Mail Routing Slips
If you choose the File menu’s Send To command, you’ll also notice a Routing Recipient
command. The Routing Recipient command lets you build a list of e-mail addresses to which
an Excel workbook can be sequentially routed, and then send the workbook to the first person
on the list. When one recipient finishes with the workbook, Excel automatically routes, or
sends, the workbook along to the next person on the list.

NOTENOTENOTENOTENOTE The Routing Recipient command lets you have a group of people make workbook
changes sequentially, which means that you avoid the sorts of conflicts described in
the earlier discussions of workbook sharing and merging workbooks.

Sending a WSending a WSending a WSending a WSending a Workbook Using Routing Slipsorkbook Using Routing Slipsorkbook Using Routing Slipsorkbook Using Routing Slipsorkbook Using Routing Slips
To use the Routing Recipient command, open the workbook you want to share and then
follow these steps:

1. Choose the Routing Recipient command.

Excel displays the Routing Slip dialog box (see Figure 7-16).

Figure 7-16 The Routing Slip dialog box you use to create a routing recipients list.
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2. Build your list of recipients.

Click the Address button to display the Address Book. To add a name, click it and then
click the To button. If you want to send the workbook to someone not yet in your Ad-
dress Book, first add his or her name to your Address Book. You should add names in
the same order as you want to route the workbook, but if you don’t, note that you can
use the Move buttons to move a selected name up or down the routing list.

3. Optionally, provide a message subject and message text.

You can use the Subject and Message Text boxes to provide the e-mail message subject
and message text. Each recipient sees this information.

4. Indicate you want to use sequential routing.

Click the One After Another option button to indicate that you want to use sequential
routing. You don’t have to use sequential routing, but sequential routing is often desir-
able. Sequential routing eliminates the need to resolve conflicting edits to a workbook.
(What happens, of course, is that recipients will effectively resolve conflicts as they re-
view the previous recipient’s work and make further changes.)

NOTENOTENOTENOTENOTE If you want the workbook returned after the last person on the list finishes, select the
Return When Done check box. If you want to receive notification each time the
workbook is routed to the next recipient, select the Track Status check box.

5. Route the workbook to the first routing recipient.

You can begin routing the workbook in two ways: immediately or later. If you want to
immediately begin routing the workbook, click the Route button; Excel sends the work-
book to the first routing recipient on your list. If you want to make more changes or post-
pone routing, click the Add Slip button; Excel then saves your routing information. When
you later want to send the workbook to the first routing recipient, choose the File menu’s
Send To command and then choose the Send To submenu’s Next Routing command.

NOTENOTENOTENOTENOTE When a routing slip is attached to a workbook, Excel replaces the Send To submenu’s
Mail Recipient command with the Next Routing command.

Receiving a Routed WReceiving a Routed WReceiving a Routed WReceiving a Routed WReceiving a Routed Workbookorkbookorkbookorkbookorkbook
You receive a routed workbook in the same manner as you receive other e-mail attachments,
as described in the earlier section, “Receiving a Workbook via E-Mail.” When you finish
with the workbook, however, choose the File menu’s Send To command and choose the Send
To submenu’s Next Routing command to send the workbook to the next routing recipient.

NoteNoteNoteNoteNote Excel provides these same instructions at the end of the e-mail message that goes along
with your routed workbook.
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When you choose the Next Routing command, Excel displays the Routing Slip dialog box
(see Figure 7-17.) Click the Route Document To option button, and then OK to send the
workbook to the next recipient.

Figure 7-17 The Routing Slip dialog box you use to pass the workbook to the next recipient.

NOTENOTENOTENOTENOTE If you click the Send Copy Of Document Without Using The Routing Slip option but-
ton, Excel lets you send the workbook as an attachment to somebody besides the next
person on the routing list and without a routing slip. This option is equivalent, then,
to the Mail Recipient command, which appears on the Send To submenu when a
workbook doesn’t have a routing slip.

Sharing Excel Data Over the WSharing Excel Data Over the WSharing Excel Data Over the WSharing Excel Data Over the WSharing Excel Data Over the Webebebebeb
Excel 2000 provides a special command—the File menu’s Save As Web Page command—
for creating a web page version of an Excel workbook. You can also use the Save As Web
Page command for creating interactive spreadsheet components for web pages. The para-
graphs that follow describe how you do both of these things—and also explain why you will
rarely want to do either.

Creating a WCreating a WCreating a WCreating a WCreating a Web Page Veb Page Veb Page Veb Page Veb Page Version of an Excel Wersion of an Excel Wersion of an Excel Wersion of an Excel Wersion of an Excel Workbookorkbookorkbookorkbookorkbook
Excel lets you use HTML as the format for your Excel workbooks. What this means is that
you can create Excel workbooks that can both be opened and edited by Excel in almost the
usual way and viewed using your web browser. (If an Excel workbook is viewed with a web
browser, you can’t edit the workbook data except in very limited circumstances, as described
later in the section “Creating an Interactive Spreadsheet Component.”)

Before I describe the steps for saving an Excel workbook using the web page, HTML for-
mat, let me say that you don’t want to use HTML as the default format for your workbooks.
Much workbook information is lost and much workbook functionality is sacrificed when
you use the HTML file format.
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NOTENOTENOTENOTENOTE You may be able to get a more complete list of the lost functionality that stems from
using HTML as the Excel workbook file format from the Office Assistant. But know
for starters that with HTML you lose the following items: the 1904 data system, ar-
rays, cell comments, conditional formatting, custom views, data validation, external
link references, formatting (including cell-level fonts, dashed and dotted borders,
pattern fills, rotated and indented text), nested functions, password protection,
precision-as-displayed options, range names, and scenarios.

To create a web page version of an Excel workbook, follow these steps:

1. Choose the File menu’s Save As Web Page command.

Excel displays the Save As dialog box (see Figure 7-18).

Figure 7-18 The Save As dialog box.

2. Name the web page.

Click the File Name box, and enter the filename you want to use for the web page.

3. Verify that the Save As Type box indicates the file format is Web Page, or HTML.

Excel lets you use either its standard binary file format, indicated by the .xls file exten-
sion, or its new web page format, indicated by the .htm file extension. When you save a
workbook as a web page, predictably, you use the web page format.

4. Specify where you want the web page saved.

Use the navigation bar’s clickable icons to open the folder location where you want to
save the web page. Most often, you click the My Documents icon so that Excel opens
your My Documents folder. You can also click the Web Folders icon so that Excel dis-
plays a list of web folders to which you can add files.
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NOTENOTENOTENOTENOTE If you don’t see any web folders listed when you click the Web Folder icon, click Cre-
ate New Folder. When Excel displays the Add Web Folder dialog box, type the web
folder URL in the box provided. Or, click the Browse button, and then use your web
browser to open the web folder location.

5. Click Publish to create the web page.

When you click Publish, Excel creates an HTML, or web page version, of the workbook
in the specified location.

Once you create the web page, you can view it using your web browser. Or, you can open
the web page using Excel and then make the same general changes you make to any Excel
workbook.

NOTENOTENOTENOTENOTE If you do create web page versions of Excel workbook, you may want to develop
proficiency in using the Insert menu’s Hyperlink command. This command lets you add
hyperlinks to a workbook—essentially by selecting the item you want to turn into a
hyperlink, choosing the command, and then providing the Internet URL.

Creating an Interactive Spreadsheet ComponentCreating an Interactive Spreadsheet ComponentCreating an Interactive Spreadsheet ComponentCreating an Interactive Spreadsheet ComponentCreating an Interactive Spreadsheet Component
Excel also lets you take Excel worksheets or worksheet ranges and convert them into min-
iature spreadsheet objects that can be placed in web pages. These interactive spreadsheet
components allow people to view the web page with their web browser. Figure 7-19, for
example, shows a simple mortgage calculator workbook. Figure 7-20 shows a web page with
a simple interactive spreadsheet component, which is actually the worksheet range A1:B5
from the workbook shown in Figure 7-19.

Figure 7-19 A simple workbook such as might be used to create an interactive spreadsheet component.
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Figure 7-20 A web page with a simple interactive spreadsheet component.

The unique feature of an interactive spreadsheet component is that when you view the
component using Microsoft Internet Explorer version 4.1(or a later version), you can make
modest changes. In Figure 7-20, for example, if you enter a new interest rate, the interac-
tive spreadsheet component calculates a new monthly mortgage payment.

In general, interactive spreadsheet components resemble Excel workbooks in their mechan-
ics. Note, however, that someone familiar with Excel will need to experiment a bit in order
to become proficient with interactive spreadsheet components.

As with Excel web pages, however, interactive spreadsheet components allow for only a sub-
set of Excel’s functionality. And, in fact, by using interactive spreadsheet components, you get
only a very modest portion of Excel’s functionality. What’s more, for someone to use interac-
tive spreadsheet components, the person must already have installed the Standard, Professional,
or Premium version of Microsoft Office 2000 and the Office Web Components.

Accordingly, one has to wonder when interactive spreadsheet components would ever be
the preferred method for sharing Excel data. Any time you can successfully share data us-
ing an interactive spreadsheet component, you’ve always got a superior solution that the
recipient presumably already knows how to use: Excel.
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Nevertheless, creating interactive spreadsheet components is easy. To create an interactive
spreadsheet component, first select the worksheet range that you want to use as an
interactive spreadsheet component. Then follow these steps:

1. Choose the File menu’s Save As Web Page command.

Excel displays the Save As dialog box (see Figure 7-21).

Figure 7-21 The Save As dialog box filled out to create an interactive spreadsheet component.

2. Click the Selection option button.

This tells Excel you want to create a web component for the selected portion of the
workbook.

3. Select the Add Interactivity check box.

This tells Excel you want to create an interactive web component for the selected por-
tion of the workbook.

4. Name the web page.

Click the File Name box, and enter the filename you want to use for the web page.

5. Specify where you want the web page saved.

Use the navigation bar’s clickable icons to open the folder location where you want to
save the web page. Most often, you click the My Documents icon so that Excel opens
your My Documents folder. You can also click the Web Folders icon so that Excel dis-
plays a list of web folders to which you can add files.

NOTENOTENOTENOTENOTE If you don’t see any web folders listed when you click the Web Folder icon, click Cre-
ate New Folder. When Excel displays the Add Web Folder dialog box, type the web
folder URL in the box provided. Or, click the Browse button, and then use your web
browser to open the web folder location.
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6. Optionally, give the web page a name.

If you click the Change Title button, Excel displays a dialog box you can use to name
the web page. This web page name appears on the title bar of the web browser.

7. Click Publish to create the web page.

When you click Publish, Excel displays the Publish As Web Page dialog box (see
Figure 7-22).

Figure 7-22 The Publish As Web Page dialog box.

8. Verify the worksheet selection.

Review the Choose boxes to confirm that these correctly identify the worksheet selec-
tion you want to publish as an interactive spreadsheet component. Edit the contents if
needed.

9. Verify the form of interactivity.

Confirm that the Add Interactivity With check box shows the correct form of interactivity.
For example, if you’re creating an interactive spreadsheet component, the list box should
show Spreadsheet Functionality.

10. Verify the filename.

Confirm that the file pathname shows in the File Name box. If the correct file pathname
doesn’t show in the File Name box, edit the contents as needed.

11. Publish the interactive spreadsheet component.

Click the Publish button.
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Retrieving External Data with ExcelRetrieving External Data with ExcelRetrieving External Data with ExcelRetrieving External Data with ExcelRetrieving External Data with Excel
Most of the earlier sections of this chapter presuppose you use Excel to create data you then
pass along to other programs and people. While many people are very likely to use Excel
in this way, you may use Excel to retrieve data created or stored by some other program.

In the final pages of this chapter, then, I’ll briefly explain how to use Excel to collect exter-
nal data so you can exploit Excel’s analytical power to examine the data. Specifically, the
chapter discusses two tools: Excel’s Import Wizard and its Get External Data commands.

Importing TImporting TImporting TImporting TImporting Textual Data into Excelextual Data into Excelextual Data into Excelextual Data into Excelextual Data into Excel
Excel lets you easily import textual data into an Excel workbook. This capacity may not sound
interesting, but it means that anything you can get as a text file—such as a financial report
generated by the mainframe accounting system—can be imported into Excel and then
examined.

To import a text file into Excel, follow these steps:

1. Open the text file.

Using the File menu’s Open command, tell Excel that you want to open the text file.
When Excel displays the Open dialog box, select the All Files item or the Text File items
in the List Files Of Type box so that your text file is listed. Once you find the file, click
it and then click the Open button. Excel displays the first Text Import Wizard dialog
box (see Figure 7-23).

Figure 7-23 The first Text Import Wizard dialog box.

2. Indicate whether the file uses the fixed-width format or delimiting characters.
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Use the Original Data Type option buttons—Fixed Width or Delimited—to indicate
whether the file uses a fixed-width format, which is the same thing as a straight text file,
or uses delimiting characters. Excel can usually guess correctly about which format your
text file uses, by the way, so if you’re not sure which option to select, accept Excel’s de-
fault suggestion.

3. Indicate the first row that should be imported.

Use the Start Import At Row box to indicate which row of the text file is the first row
you want to have imported. For example, you might not want to import reader header
and title information, and might instead want only to begin importing the first row with
the data.

4. Identify the file origin.

Use the File Origin box to identify the source of the file. If you’re importing data cre-
ated by another Window’s program, select the Windows (ANSI) entry from the File
Origin box. If you’re importing data from a mainframe, select the MS-DOS (PC-8) entry
from the File Origin box.

NOTENOTENOTENOTENOTE You can use the Preview box to see how Excel interprets your to-be-imported data.

5. Verify the fixed-width assumptions or delimited character assumptions made by Excel.

Once you finish with the first Text Import Wizard dialog box, you click Next. Excel then
displays the second Text Import Wizard dialog box. If you’re importing a fixed-width
file, Excel displays the dialog box shown in Figure 7-24. You use this dialog box to verify
how Excel breaks the text file into columns. You can create new break lines by clicking.
You can remove an existing break line by double-clicking. You can also move an exist-
ing break line by dragging.

Figure 7-24 The second Text Import Wizard dialog box if you’re importing a fixed-width file.
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If you’re importing a delimited character file, Excel displays the dialog box shown in Figure
7-25. You use this dialog box principally to verify that Excel has correctly identified the
delimiter: The checked Delimiters box should identify the delimiter. You can also indi-
cate if the text file uses a character (such as a quotation mark) to identify text. Note that
you can tell whether Excel’s delimiter assumptions correctly describe the text file because
the preview box shows how your data look given the delimiter specifications.

Figure 7-25 The second Text Import Wizard dialog box if you’re importing a delimited character file.

6. Select formatting for each column.

After you’ve verified the fixed-width or delimited character assumptions of Excel—and
fixed any incorrect assumptions—click Next. Excel displays the third Text Import Wizard
(see Figure 7-26). You use this dialog box to specify the formatting assumptions Excel
should make about the to-be-imported text file.

Figure 7-26 The third Text Import Wizard dialog box.
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Excel also guesses about the default formatting that it should use for each column of the
text file you import. You should verify that each column uses the best default formatting.
To change a column’s format, click the column header and then the appropriate Column
Data Format button. If you don’t want to import a column, click it and then click the
Do Not Import Column option button.

7. Click Finish when you’re finished.

Excel imports the text file into a new, blank, open workbook. At this point, you’re ready
to begin cleaning up the data so you can start working with it.

Using the Get External Data CommandsUsing the Get External Data CommandsUsing the Get External Data CommandsUsing the Get External Data CommandsUsing the Get External Data Commands
Excel, through the commands on the Get External Data submenu, provides tools that you
can use to retrieve data from external data sources, such as from a database. Some of these
tools are quite easy to use. And others require you to be proficient in the language and struc-
ture of databases. I’m not going to describe how to use all of these tools in detail here. I will,
however, describe how you use the most common of these tools, including the Query Wizard.
And I’ll also discuss each of the tools so you know just what Excel is capable of and about
features you may want to explore in more detail.

Importing TImporting TImporting TImporting TImporting Text Filesext Filesext Filesext Filesext Files
If you choose the Data menu’s Get External Data command and then choose the Get
External Data submenu’s Import Text File command, Excel lets you identify a text file you
want to import.  Once you’ve identified this text file, Excel starts the same Text Import
Wizard described in the previous section, “Importing Textual Data into Excel.”

When you use the Import Text File command, however, Excel does one thing differently
from starting the Text Import Wizard from the File menu’s Open command. When you
use the Import Text File command, Excel maintains a link to the original text file by using
external references. This means that if you want to re-import the text file—perhaps because
the data has changed—you can easily do so. To re-import the data, click the Refresh All
toolbar button on the External Data toolbar.

NOTENOTENOTENOTENOTE If you don’t see the External Data toolbar, right-click on another toolbar and choose
the External Data command when Excel displays the shortcut menu.
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Using the Query WizardUsing the Query WizardUsing the Query WizardUsing the Query WizardUsing the Query Wizard
Excel’s Get External Data submenu provides access to the Query Wizard, which is the tool
you’ll most often use to retrieve external data. The Query Wizard, in effect, provides an
interface you use from inside Excel to query an external database.

The Query Wizard works with most common databases. Excel provides database drivers
for connecting to most (perhaps all) of the popular database engines, including the Microsoft
Access 2000, Excel, FoxPro, and SQL Server products; and the third-party database prod-
ucts dBase, Oracle and Paradox.

If you want to retrieve information from an external database that isn’t on the list contained
in the preceding paragraph, you can still retrieve data from the database. For example, al-
most surely, you can use the database program to create a text file that holds the informa-
tion you want to query. And you may also be able to create database files, or tables, that use
a format that mimics one of the databases listed.

NOTENOTENOTENOTENOTE To import a text file, you use the Text Import Wizard. As noted in the preceding para-
graphs, you can start the Text Import Wizard indirectly by choosing the File menu’s
Open command and then attempting to open the text file. Or you can start the Text
Import Wizard directly by choosing the Data menu’s Get External Data command and
then choosing the Get External Data submenu’s Import Text File command.

To use the Query Wizard, follow these steps:

1. Open a blank workbook.

Excel places the external data you retrieve in the open workbook. This means you’ll prob-
ably want to start with a blank open workbook. If you want to place the data in an exist-
ing workbook, make sure you’ve got an empty worksheet on which to store the data.

2. Start the Query Wizard.

To start the Query Wizard, first choose the Data menu’s Get External Data command.
When Excel displays the Get External Data submenu, choose the New Database Query
command. Excel displays the Choose Data Source dialog box (see Figure 7-27).

Figure 7-27 The Choose Data Source dialog box.



Chapter 7Chapter 7Chapter 7Chapter 7Chapter 7 Sharing Workbooks 245245245245245

3. Indicate you want to use the Query Wizard.

Check the Use The Query Wizard To Create/Edit Queries box to indicate you’ll use the
Query Wizard.

4. Indicate the data source from which you’ll retrieve the data.

To select the data source from which you want to retrieve data, first click the Databases
tab. Then select the type of database from which you’ll retrieve data. For example, if you’re
retrieving data from a nonshareable dBase database, click the dBase (not sharable) en-
try in the list box. Click OK after you’ve selected your data source. The Query Wizard
displays the Choose Columns dialog box (see Figure 7-28).

Figure 7-28 The Choose Columns dialog box.

NOTENOTENOTENOTENOTE If you want to rerun an existing query, click the Queries tab to see a list of defined
queries you can use to get external data. You can also click the OLAP Cubes tab to
see a list of OLAP data sources that may be available.

5. Select the table or tables that you want to query.

When Excel displays the Choose Columns dialog box, use the Available Tables And
Columns list box to select the tables and columns, or fields, that you want to import. To
see the columns that a table uses, click the plus symbol next to the table name.

6. Select the columns that you want to retrieve.

Using the Choose Columns dialog box, select the columns you want to retrieve. To se-
lect a column, click the column and then click the Add button. The Add button shows
a single arrow pointing to the Columns In Your Query list box. To remove a column from
the Columns In Your Query list box, click the column and then click the Remove but-
ton, which shows a single arrow pointing to the Available Tables And Columns List box.
To start over, click the Remove All button, which shows a double arrow pointing to the
Available Tables And Columns List box. When you finish selecting the columns you want
to retrieve, click the Next button. The Query Wizard displays the Filter Data dialog box
(see Figure 7-29).
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Figure 7-29 The Filter Data dialog box.

7. Describe the data the Query Wizard should retrieve.

To describe the data you want to retrieve, use filters based on the columns, or fields, that
you’re querying. To create a filter, select the column you want the query to examine. Then
use the Only Include Rows Where boxes and buttons to indicate how this column is
examined. Figure 7-29, for example, shows a filter that looks at the BALANCE_TO
column to see whether this value is greater than or equal to 0. The first drop-down list
box in the Only Include Rows Where area provides other logical operators you can also
use. If you want to create a filter based on more than one comparison of the same col-
umn, use the And and Or option buttons and the next row of boxes. If you want to cre-
ate a filter based on another column, select the column from the Columns To Filter list
box and then repeat the preceding steps. When you finish specifying the filters you want
to use, click Next. The Query Wizard displays the Sort Order dialog box (see Figure 7-30).

Figure 7-30 The Sort Order dialog box.
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8. Select a sort order for the retrieved data.

When Excel displays the Sort Order dialog box, use the Sort By box and the Ascending
and Descending option buttons to indicate how the retrieved data should be arranged
in your worksheet. If some of the records, or rows, will use the same first sort key—this
is what you specified using the Sort By box—you can provide a second sort key using the
first Then By box and buttons. You can also provide additional sort keys using the other
Then By box and buttons. When you finish specifying the sort order, click the Next
button. The Query Wizard displays the Finish dialog box (see Figure 7-31).

Figure 7-31 The Finish dialog box.

9. Tell the Query Wizard where you want to place the data that the query returns.

When the Query Wizard displays the Finish dialog box, use the What Would You Like
To Do Next option buttons to select a location for the data. Presumably, you want to place
the retrieved data in an Excel worksheet so you can use Excel’s analytical tools to exam-
ine the data in ways that the database program doesn’t allow. To do this, click the Re-
turn Data To Microsoft Excel button. Then click Finish. Excel runs the query and asks
where the retrieved data should be stored using the Returning External Data To Microsoft
Excel dialog box (see Figure 7-32).

Figure 7-32 The Returning External Data To Microsoft Excel dialog box.
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NOTENOTENOTENOTENOTE If you want to save the query so you can use it again, click the Finish dialog box’s Save
button. Then when Excel displays the Save As dialog box, use the File Name box to
give the query a name. Once you’ve done this, click Save to save the query for future use.

10. Select a location for the retrieved data.

When Excel asks where the retrieved data should be placed, use the Where Do You Want
To Put The Data option buttons to select a location for the data: in the open workbook
at the location of the cell selector, in a new workbook, or in a PivotTable report. Then
click OK. Excel places the data in the indicated location.

After you place the retrieved data in an Excel workbook, you can begin to work with the
data using Excel’s features. You can use statistical functions to look closely at the data’s
characteristics, for example. And you can use charts to view and present the data visually.

The External Data toolbar, which Excel will probably display, provides several toolbar buttons
you’ll find useful, too. The Edit Query button, for example, restarts the Query Wizard so
you can change the query. The Data Range Properties button displays the External Data
Range Properties dialog box, which you can use to change the way that Excel handles the
data it retrieves in the query. The Query Parameters button lets you describe how any query
parameters are handled in the query. The Refresh Data button reruns the query to retrieve
any new data. The Cancel Refresh button stops a refresh you might have started. The Re-
fresh All button reruns all the queries in a workbook. Finally, the Refresh Status button
displays a dialog box that reports information such as how long a refresh operation took.

NOTENOTENOTENOTENOTE A query parameter is a value that you’ve said you will supply to the query before or
as it runs. The Query Wizard doesn’t let you create query parameters. If you create
from-scratch queries using Microsoft Query, which is discussed briefly in the later
section “Using Microsoft Query,” you can use query parameters.

Running a WRunning a WRunning a WRunning a WRunning a Web Queryeb Queryeb Queryeb Queryeb Query
The Get External Data submenu provides a Web Query tool that you can use to retrieve
tabular data from a web page. To run a simple web query, open a blank workbook, choose
the Data menu’s Get External Data command, and then choose the Get External Data
submenu’s New Web Query command.

NOTENOTENOTENOTENOTE Excel also comes with several web queries already set up and saved, which you can
run by choosing the Data menu’s Get External Data command and then choosing the
Get External Data submenu’s Run Saved Query command. When you do this, Excel
displays the Run Query dialog box, which lists the saved queries. Excel places a small
globe icon in front of the saved web queries. To run one of the saved web queries,
click it and then click the Get Data button.
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If you choose the New Web Query command, Excel displays the New Web Query dialog
box (see Figure 7-33). To use the New Web Query dialog box, click the Browse button and
then open the web page with the table from which you want to retrieve information. Once
you’ve displayed this web page, return to Excel by clicking the Excel taskbar button. As this
point, you can click OK and Excel will retrieve the table data. When Excel asks where the
data should be placed using the Returning External Data To Microsoft Excel dialog box
(see Figure 7-32), indicate the appropriate location.

Figure 7-33 The New Web Query dialog box.

You can use the other option buttons in the New Web Query dialog box to attempt to control
what data the Web Query tool retrieves and how this data is formatted as Excel places it
in your workbook. Your best bet in working with these options is probably just to experi-
ment and see which option settings produce the best results.

NOTENOTENOTENOTENOTE The more you know about HTML, the more you can do with the Web Query tool. If
you know HTML well, for example, you can use the New Web Query dialog box to
specify that only specific tables should be retrieved from a web page.

Using Microsoft QueryUsing Microsoft QueryUsing Microsoft QueryUsing Microsoft QueryUsing Microsoft Query
The Query Wizard, described in the earlier chapter section “Using the Query Wizard,” provides
you with a simple way to access external data. You should know, however, that the Query Wiz-
ard is a tool you use to tell another program, Microsoft Query, how you want to query an exter-
nal database. While the Query Wizard works well in most simple situations, you don’t get access
to all of Microsoft Query’s power when you work through the wizard.
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When you want more control over how a query operates, you can work directly with
Microsoft Query. To work directly with Query, you also start by choosing the Data menu’s
Get External Data command and then choosing the Get External Data submenu’s New
Database Query command. As with a query performed using the Query Wizard, when Excel
displays the Choose Data Source dialog box (see Figure 7-27), you select the database source.

To work directly with Query, however, you clear the Use The Query Wizard To Create/Edit
Queries check box. When you click OK, Excel starts Microsoft Query.

NOTENOTENOTENOTENOTE For more information on using the Choose Data Source dialog box, refer to the ear-
lier section “Using the Query Wizard.”

To use Query, you follow a process similar to that used with the Query Wizard. For example,
you start by identifying which tables you want to query, which columns, (or fields) you want to
retrieve, how you want to filter, and how the data you retrieve should be sorted. Although Query
provides less handholding than that of the Query Wizard, it offers you greater flexibility.

A more detailed discussion of Query is beyond the scope of this book, but let me make two
final observations: First, before you attempt to develop expertise or fluency with Query, make
sure that you won’t get further faster simply by learning how to use the external data source’s
query capabilities. For example, Access is easier to learn (in part because it’s better docu-
mented) and more useful than Query. It may not be a good use of your time, to learn Query
so that you can then query an Access database. Instead, you might be better off learning Access.

Second, the Excel Help file provides detailed information about how to use Microsoft Query.
To access this information, ask the Office Assistant a question such as, “How do I work with
Microsoft Query?” Then explore the help topics that the Office Assistant provides.


